ubuntu 安装 libssl-dev失败的解决方案

2020-02-18阅读(133)评论(0)牵着狗狗看MM

苏州实时公交查询

ubuntu下使用如下命令安装libssl-dev时,

sudo apt-get install libssl-dev

如果报错提示大致意思为,已安装的libssl版本太高,那么请尝试如下操作:

解决方案:

使用aptitude软件包管理器

1.安装aptitude

sudo apt-get install aptitude

2.用aptitude安装libssl-dev,采用建议的解决方案(将libssl1.0.0版本降级)

sudo aptitude install libssl-dev

安装的时候,会询问3次(这里就不多作解释了),依次按下  NY Y

等待安装完成。

3.验证libssl-dev安装情况

dpkg -l *libssl*

 

如果想要安装其他lib库,如libsqlite3-dev 也是按照如上方法操作即可

赞(0) 打赏
转载请注明来源:Web前端(W3Cways.com) - Web前端学习之路 » ubuntu 安装 libssl-dev失败的解决方案
分享到: 更多 (0)

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏